Announcement

Collapse
No announcement yet.

DM780 6.4.0.787 hangs

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • DM780 6.4.0.787 hangs

    Hi a
    I have update my HRD from 6.4.0.780 to 6.4.0.787 version. Before the update all was working well but now DM780 is too bad to work with.
    It takes too much time to start and can't be used, it is slow it hangs after every action i start. Not useable at all.
    It runs under Windows10.

    Any ideas, every help is welcome
    73's André de PD2AM
    Last edited by PD2AM; 10-27-17, 15:51.

  • #2
    Andre,

    For now, go back to v.780 ..... If you didn't save a copy, you can get v.780 on the HRD web page ... https://www.ham-radio-deluxe.com/downloads/
    Ron, W3RJW

    HRD v6.4.0.780
    Acer Aspire XC600, Intel Pentium Dual Core 2.9GHz, 8 GB Memory, 64-bit OS, Windows 8.1,
    Access Data Base
    FTdx-5000+Timewave Navigator Interface/FTdx-3000+SignaLink USB Interface, SteppIR Interface

    Comment


    • #3
      I am having DM780 waterfall to freeze or hangup or become partially inop in CW mode. Most occasions when this happens it has been running for a period of time and when I get back to DM the waterfall tool bar is grayed out at this point I cannot change modes or move the decode bar it will not change bands or freqs by the band buttons these are all grayed out also the squelch bar does not work it will no longer move. The last time this happened it was very shortly after opening DM and selecting CW mode. I have not seen this happen in any other mode but the only modes I have used is BPSK-31and RTTY. I did try going to HRD version 780 and it did the same thing with this version so I am back to 787. My system is Dell 660 I5 proc win10 home, 8GB ram, HRD-787 rig is FT1000MP on serial cable and I use a second serial port with a small transistor to key this rig in CW. Only way out is shut down DM and I get a beep from computer when I do shut it down then restart DM and it will again work. Attached a screen shot of it while acting up. Any thoughts? thanks 73 Morris WA4MIT froze.jpg
      Last edited by WA4MIT; 11-10-17, 22:53.

      Comment


      • #4
        WA4MIT -
        I notice on the screen shot that the SEND button is greyed out, so you're stuck in TX mode. In CW mode, that usually comes from trying to send a short macro.
        If you're using CW Winkey, you can just tap the paddle to break out of TX. This is a known bug.
        If not using Winkey, I'm not sure how to break the loop, other than a restart as you do.
        73,
        Ed - W4ELP

        Comment


        • #5
          It is not in TX mode at least TX is not keyed up, it will still rx & tx via macros. I know the RX is working for sure. I only try to use CW to work a few DXPD`s that I can copy if they are machine sent. I am not CW op at all but I manage to work some of the DX this way. Don`t use this a lot but it is a nuisance when it freezes like this. No CW Winkey just using a transistor off a serial port to key the MP. Thanks Ed 73 Morris wa4mit

          Comment


          • #6
            Morris-
            I still believe that DM780 is remaining in TX mode. Note that the "Send (F4)" button is greyed out, and the "Stop (F5)" button is visible. Also, the "Tuning indicators" are visible (square bulls eye in lower right corner of waterfall) which indicate TX mode. If you're using the radio's CW VOX, the radio won't stay keyed up when you're not actually sending CW characters.

            I see you're in basic CW mode. I tried getting mine (v787) to hang or lock up in TX, and can't get it to do that.
            Have you tried just clicking the "Stop (F5)" button, or hitting F5?
            Right-click each of your CW macros and make sure they either end with <stop> or the autostop box is checked. If DM780 is not told to stop after a macro, it would remain in TX mode and would behave as you described - you would be able to receive, and subsequent macros would work.
            Hope this helps.
            73,
            Ed - W4ELP

            Comment


            • #7
              I see what you mean putting it in TX does show the same screen symptoms but why would it go into TX ? Ed I believe your right but that still leaves me not knowing how it gets into TX I put the MP in VOX and unless there are characters to send it does not key up the radio. Strange I will do more checking next time it does this Ed right now it is working.Well I think I found what was happening, I work a lot of FT8 mode with WSJT-X and it uses F4 as a clear key and that is TX in DM and with DM running and in CW that puts DM into TX so Ed you were correct and many thanks. 73 Morris
              Something to add: DM F4 only works if DM is in the forefront (focus) of the computer screen as long as WSJT-X is the focus using F4 does not cause DM to swich to TX mode even when DM is the background of WSJT-X it does not cause DM to switch so that sort rules that out it seems
              Last edited by WA4MIT; 11-12-17, 13:43.

              Comment


              • #8
                Morris, you're right about F4 not activating TX if DM is not in focus. But I think you're on the right track and very close to finding the solution.
                73, Ed - W4ELP

                Comment


                • #9
                  You know Ed why has this not happened in PSK or RTTY if it happened in psk or tty it would key up and put out a signal. But it only seem to happen in CW???
                  Morris wa4mit

                  Comment


                  • #10
                    Morris, that's a good question for which I don't have an answer. It'll probably keep me awake tonight.
                    73, Ed - W4ELP

                    Comment


                    • #11
                      Ed I think I found what caused the TX hang. On some of my macros I did not have "stop" as the last character and when executed this left the TX on. Only thing is why did this not happen all the time but I feel like it will not happen again after adding the stop to the macros. 73 Morris wa4mit

                      Comment


                      • #12
                        Originally posted by W4ELP View Post
                        Morris-
                        Right-click each of your CW macros and make sure they either end with <stop> or the autostop box is checked. If DM780 is not told to stop after a macro, it would remain in TX mode and would behave as you described - you would be able to receive, and subsequent macros would work.
                        That would sure do it. If I had a nickel for every time I've been bitten by the same omission...
                        73, Ed - W4ELP

                        Comment


                        • #13
                          Looks like v.780 has been removed from the downloads! In there another official source ?

                          Jerry KB2GCG

                          Comment


                          • #14
                            Originally posted by KB2GCG View Post
                            Looks like v.780 has been removed from the downloads! In there another official source ?

                            Jerry KB2GCG
                            Did you try this link:

                            https://cdn.ham-radio-deluxe.com/fil...pHRD64_780.exe

                            73,
                            Charlie, KØLAF

                            Comment

                            Working...
                            X